Weird high beam behaviour

Technical Forum for the Porsche Macan
Post Reply
penport
Posts: 19
Joined: Tue Feb 25, 2020 1:05 pm

Weird high beam behaviour

Post by penport » Sun Nov 15, 2020 6:06 pm

I have no high beam either side with the main (halogen) lights on, all of a sudden both sides stopped working despite the blue light symbol appearing in the dash. DRLs still work okay and the H15 bulb comes on when the care is first unlocked / stopped.
I have changed both H15 bulbs for new ones and there's no improvement.
Somewhat weirdly when the lights are set to 'off' (on the rotary knob) the stalk flasher works okay.
I've checked the fuse and all okay.

I'm beginning to think this is a wiring issue and I need to seek out an auto electrician - but am I missing something?

Nothing in the manual helps.

Thoughts appreciated
2015 Macan S Sapphire Blue PSE, PSP, PASM, Cobb AP, K&N

Ti Rich
Posts: 121
Joined: Mon Feb 24, 2020 8:35 pm

Re: Weird high beam behaviour

Post by Ti Rich » Wed Nov 18, 2020 12:21 pm

Not sure how you are testing but was the engine running at the time?

Also try moving the selector switch to the dipped beam position as in "auto" they may only work when dark.
2017 Macan S D, 21" Classics, PASAM, Black Exhausts, Heated seats / Steering Wheel, Nav, Park Assist.

penport
Posts: 19
Joined: Tue Feb 25, 2020 1:05 pm

Re: Weird high beam behaviour

Post by penport » Wed Nov 18, 2020 1:15 pm

Thanks Ti Rich
Yes I’ve tested all those scenarios.

I think the issue may have been around for a while as with lockdown I’ve only recently been driving in the dark. Country lanes are interesting atm but better since I upgraded to Philips LED H7 as per your advice.

Booked in to a local auto electrician on Friday so will update then.
2015 Macan S Sapphire Blue PSE, PSP, PASM, Cobb AP, K&N

Ti Rich
Posts: 121
Joined: Mon Feb 24, 2020 8:35 pm

Re: Weird high beam behaviour

Post by Ti Rich » Thu Nov 19, 2020 11:21 am

OK, good luck. Upgrading H7 bulb to the Philips really makes a difference!
2017 Macan S D, 21" Classics, PASAM, Black Exhausts, Heated seats / Steering Wheel, Nav, Park Assist.

DaveS
Posts: 52
Joined: Fri Jun 06, 2014 11:07 am

Re: Weird high beam behaviour

Post by DaveS » Fri Nov 20, 2020 3:39 pm

Had an issue on my previous Macan with lights and eventually it was traced to the switch. OPC replaced it and all was good. At times no mater what position the switch was in the lights wouldn't switch off.
Dave

penport
Posts: 19
Joined: Tue Feb 25, 2020 1:05 pm

Re: Weird high beam behaviour

Post by penport » Fri Nov 20, 2020 5:19 pm

Well my local auto electrician reckons it's an issue with the headlamp control module.

Looks like a visit to OPC
2015 Macan S Sapphire Blue PSE, PSP, PASM, Cobb AP, K&N

Post Reply